aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bf11705
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,28 @@
+bin_PROGRAMS = aeroup
+
+ext_src =
+if BOOST
+ext_src += serialboost.cpp
+ext_src += regboost.cpp
+#echo have boost
+else
+ext_src += reglinux.cpp
+ext_src += seriallinux.cpp
+#echo have not boost
+endif
+
+aeroup_SOURCES = \
+ main.cpp \
+ ultimate.cpp \
+ serialprop.cpp \
+ optmanager.cpp \
+ gloseq.cpp \
+ buffer.cpp \
+ buffermanager.cpp \
+ rules.cpp \
+ ${ext_src}
+
+aeroup_CPPFLAGS = -W -Wall -std=c++11
+aeroup_LDFLAGS =
+#LIBS +=
+#-DSERIAL_BOOST_LIB