aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBarattero Laurent <laurent@larueluberlu.net>2014-01-21 04:02:33 +0100
committerBarattero Laurent <laurent@larueluberlu.net>2014-01-21 04:02:33 +0100
commit98f60a7659f12e0474ecd3fed0632a059fb4133f (patch)
tree8f10736fec6777df15b70230489429d45978cd0f /configure.ac
parent6ed6128396063cc4d1676d41fb63517eb29162e4 (diff)
update to version 0.3.0
adds improved driver support for linux
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5e50b3c..5c9e857 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
AC_PREREQ([2.69])
AC_CONFIG_AUX_DIR([build-aux])
-AC_INIT([AeroUp], [0.2], [laurentba<at>larueluberlu.net], , [https://github.com/LaurentBa/AeroUp])
+AC_INIT([AeroUp], [0.3.0], [laurentba<at>larueluberlu.net], , [https://github.com/LaurentBa/AeroUp])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([src/global.hpp])
AC_CONFIG_HEADERS([src/config.h])
@@ -78,10 +78,19 @@ AC_CHECK_FUNCS([memset regcomp strtol])
AC_CHECK_FUNCS([bzero memset strtol])
AC_CONFIG_FILES([Makefile
- src/Makefile])
+ src/Makefile
+ udev/Makefile])
+
AM_CONDITIONAL([BOOST], [test "$HAVE_BOOST_REGEX" = yes])
+# UDEV
+AC_MSG_CHECKING([For Udev])
+AM_CONDITIONAL([UDEV], [test -d "/etc/udev/rules.d" ])
+AM_COND_IF([UDEV], [AC_MSG_RESULT(["yes"])], [AC_MSG_RESULT(["no"])])
+
+
+
AC_OUTPUT
echo \